Project

General

Profile

Actions

Feature #488

closed

List of changes for the managed system

Added by Marcel Poul over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Radek Tomiška
Category:
Provisioning
Target version:
Start date:
06/06/2017
Due date:
% Done:

100%

Estimated time:

Description

Function specification:

Make a report in "implemented reports" module. The report will be available in CSV, JSON, XLSX formats. It will consist of all entities (e.g. Identities) and its attributes (after transformation) that has different values then the value of corresponding account in the connected system.

e.g. if there exist in CzechIdM the identity with login "xnovak" and firstName "Petr Pavel" and its corresponding account in LDAP has firstName "Petr", then the report will contain this change.

Be aware that the value that is to be compared on the IdM side is the value after the PROVISIONING transformation like this:

FirstName (IdM) -> Transformations of attributes(IdM) VERSUS firstName (MS AD).

Also keep in mind that attributes in connected system are computed from 0 or more attributes in IdM. e.g.

FirstName + SurName (IdM) -> Transformation (IdM) -> DisplayName (MS AD)

There are also some attributes that are not easy to compare, but are necessary to be available in the report. That is especially: member in AD/LDAP group - cruacial for us.

When report is being prepared by the administrator in GUI, user must be able to specify the system and entity for which the report will be created. Available are only systems that have provisioning mapping defined.

MAIN USE CASES:
  • When a connected system e.g. MS AD is to be switched from ReadOnly to ReadWrite we would like to see all changes on all provisioned entities (usually Identities).
  • Report can be sent to administrator of connected system and he can change the data or approve that IdM can overwrite the values there.

Technical design:
TOBE done by the ticket implementer


Files

report.png (201 KB) report.png Ondřej Kopr, 07/11/2018 02:13 PM
Actions #2

Updated by Radek Tomiška over 4 years ago

  • Assignee changed from Ondřej Kopr to Radek Tomiška
  • Target version set to Diamond (7.4.0)
Actions #3

Updated by Radek Tomiška over 4 years ago

  • Tracker changed from Task to Feature
Actions #4

Updated by Vít Švanda over 4 years ago

  • Target version deleted (Diamond (7.4.0))
Actions #5

Updated by Marcel Poul almost 4 years ago

  • Assignee changed from Radek Tomiška to Petr Adamec
Actions #6

Updated by Petr Adamec almost 4 years ago

  • Status changed from New to In Progress
Actions #7

Updated by Marcel Poul almost 4 years ago

  • Description updated (diff)
Actions #9

Updated by Marcel Poul almost 4 years ago

  • Description updated (diff)
Actions #10

Updated by Alena Peterová almost 4 years ago

The implementation of the report cannot depend on all possible ways to compute an account attribute during the provisioning transformation. There are so many options how to compute attributes, and so many options if the value would be really sent to the system by the provisioning.
I guess it could somehow use prepare-connector-object-processor or its methods for computing the "wished" changes for the account.

Actions #11

Updated by Petr Adamec almost 4 years ago

  • % Done changed from 0 to 50

I have pushed result of this task to branch adamecp/488-List-of-changes-for-the-managed-system

Changes:
  • new xsl report exists for provisioning
  • new report can be selected in Reports -> new report
  • You need enter system id for use it (select system for report)
  • there is header of reports on the first line. The following lines contain data of provisioning attributes of entity. One attribute lies on one row. There are informations about provisioning system, entity's type, entity's name and new value of attribute on line.
Actions #12

Updated by Petr Adamec almost 4 years ago

I added new render for reder select box for filetrin systems at provisioning report.
I made some changes on Executor and renderer on BE.
I edited integration test ( The test eill not past for now).

I pushed into branch adamecp/488-List-of-changes-for-the-managed-system

Actions #13

Updated by Radek Tomiška over 3 years ago

  • Status changed from In Progress to Needs feedback
  • Assignee changed from Petr Adamec to Marcel Poul
  • Target version set to Jade (8.1.0)
  • % Done changed from 50 to 90

I've simplified report of active provisioning operation to minimum:
- report contains list of active operations in provisioning queue with attributes, which will be provisioned (=> right side of provisioning operation detail).
- the main benefit of this report is overview on attributes, which will be provisioned to target system
- report moved to ''reports'' module, doc https://wiki.czechidm.com/devel/documentation/modules_reports

Could you do a feedback pls?

Commit: https://git.bcvsolutions.eu/modules/reports/commit/ebca3a87565e37013ffa2418537e4161df28c077
Note: Other improvements can be implemented in new tickets .

Actions #14

Updated by Radek Tomiška over 3 years ago

  • Target version deleted (Jade (8.1.0))
Actions #15

Updated by Radek Tomiška over 3 years ago

  • Assignee changed from Marcel Poul to Ondřej Kopr
  • Target version set to Lapis (8.2.0)
Actions #16

Updated by Ondřej Kopr over 3 years ago

  • File report.png report.png added
  • Status changed from Needs feedback to Resolved
  • Assignee changed from Ondřej Kopr to Radek Tomiška
  • % Done changed from 90 to 100

I deploy your new report on virtual a test it on the server. About 20k identities was propagate to read only system. Then I generate report with active items in provisioning queue. Result was amazing and it was done really quick. Screen:

9197 / 8952 - Task duration 2 minutes (the higher first number is caused by running another process that create new provisioning operation)

Thanks for complete this report. Works correctly and awesome :)

Actions #17

Updated by Radek Tomiška over 3 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF