Project

General

Profile

Actions

Task #379

closed

Resource - allow to map an attribute multiple times

Added by Filip Měšťánek over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
High
Assignee:
Vít Švanda
Category:
Synchronization
Target version:
Start date:
04/21/2017
Due date:
% Done:

100%

Estimated time:

Description

For synchronization, there should be possibility to map one resource attribute multiple times. For example I want to fill eav attributes 'name' and 'alternateName' with value of resource attribute 'name'.


Related issues

Has duplicate CzechIdM - Task #877: Mapping one schema attribute to multiple entity attributesClosedVít Švanda12/18/2017

Actions
Actions #1

Updated by Filip Měšťánek over 4 years ago

  • Category set to Synchronization
  • Assignee set to Vít Švanda
  • Priority changed from Normal to High
Actions #2

Updated by Radek Tomiška about 4 years ago

  • Has duplicate Task #877: Mapping one schema attribute to multiple entity attributes added
Actions #3

Updated by Vít Švanda over 3 years ago

  • Target version set to Lapis (8.2.0)
Actions #4

Updated by Vít Švanda over 3 years ago

  • Status changed from New to In Progress
Actions #5

Updated by Vít Švanda over 3 years ago

  • % Done changed from 0 to 70
Actions #6

Updated by Vít Švanda over 3 years ago

  • Status changed from In Progress to Needs feedback
  • Assignee changed from Vít Švanda to Ondřej Kopr
  • % Done changed from 70 to 90

Use one schema attribute multiple times is now possible but only in the synchronization mapping.
If more attributes uses same schema attribute in the provisioning mapping, then validation exception is throw.
If type of mapping is change, the validation is evaluated too.

Branch: vsvanda/375-sync-multiple-schema-attributes
https://github.com/bcvsolutions/CzechIdMng/commit/d085471c07717591630e762d515f76e6cc171e8f
Tests are here:
https://github.com/bcvsolutions/CzechIdMng/commit/0294e100e1c077dbace641e5febb2e5a25479a74

Actions #7

Updated by Ondřej Kopr over 3 years ago

  • Status changed from Needs feedback to Resolved
  • Assignee changed from Ondřej Kopr to Vít Švanda
  • % Done changed from 90 to 100

Your feature works well. I checked it with provisioning mapping and synchronization mapping. For synchronization is now possible map one and more same attribute with different IdM key. Duplicate of system also works perfectly.

Thanks for the feature. This will be helpful for projects.

Actions #8

Updated by Ondřej Kopr over 3 years ago

Feature is still in own branch.

Actions #9

Updated by Vít Švanda over 3 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF