Project

General

Profile

Feature #2160

Filter by event identifier doesn't find the event

Added by Alena Peterová 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Low
Category:
Event
Target version:
Start date:
03/30/2020
Due date:
% Done:

100%

Estimated time:
Milestones:

Description

Tested on version 9.7.11
I tried to find the reason why an IdmIdentity NOTIFY event was created, i.e. the parent event of my event. But when I put the UID to the filter, no event was found. So I think the filter "Entity type / Entity or event identifier (like)" doesn't work well.

I reproduced it with the the help of filter by date:
1. Here you can see both events - parent and the child, and parent UID


2. JSON of the same response

3. Try to filter the parent event by its UID - none is found:

events.png (37.9 KB) events.png Alena Peterová, 03/30/2020 08:59 AM
json.png (73.9 KB) json.png Alena Peterová, 03/30/2020 08:59 AM
event_not_found.png (16.5 KB) event_not_found.png Alena Peterová, 03/30/2020 08:59 AM
parent.png (8.5 KB) parent.png Alena Peterová, 03/30/2020 08:59 AM

History

#1 Updated by Radek Tomiška 8 months ago

  • Tracker changed from Defect to Feature
  • Priority changed from Normal to Low

Like operator for uuid is little specific, see field help (under help icon):
"Given uuid identifiers cannot contain dashes (short identifier can be given or dashes can be removed)."

But I can add clausule with equals (or) as UX improvement - both options can be supported

#2 Updated by Alena Peterová 8 months ago

Radek Tomiška wrote:

Like operator for uuid is little specific, see field help (under help icon):
"Given uuid identifiers cannot contain dashes (short identifier can be given or dashes can be removed)."

But I can add clausule with equals (or) as UX improvement - both options can be supported

Thanks, this works! But it really isn't much user friendly, since all other parts of IdM expect you to use the whole UID and fail when you write only part of it.
Before I created this ticket, I even clicked on the help icon, but I didn't read the text carefully because it looked like the standard text used in fulltext help icons. So this is another feedback for UX - if some text is only slightly different, but the different lines at the top please :-)

#3 Updated by Radek Tomiška 8 months ago

Thx for feedback :)
This filter was added before quick uuid links between agendas, so i wanted to support short uuid (which was shown in table) to make it a litte easier + help was added ... but i can see, every help can be pointed as bug :)

#4 Updated by Radek Tomiška 8 months ago

  • Status changed from New to In Progress
  • Target version set to 10.3.0

#5 Updated by Radek Tomiška 8 months ago

  • Status changed from In Progress to Needs feedback
  • Assignee changed from Radek Tomiška to Vít Švanda
  • % Done changed from 0 to 90

It's implemented, now is posible to use whole uuid identifier (with dashes) too, commit:
https://github.com/bcvsolutions/CzechIdMng/commit/84879f8f4e8929cb567aa68eb696fe22c5ee8013

Could you provide me a feedback, please?

#6 Updated by Vít Švanda 7 months ago

  • Status changed from Needs feedback to Resolved
  • Assignee changed from Vít Švanda to Radek Tomiška
  • % Done changed from 90 to 100

I did review and test. Filtering by full UUID format works now. Thanks for that.

#7 Updated by Radek Tomiška 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Go to top