Project

General

Profile

Task #1928

IdentityStateEnum missing in index.js

Added by Ondřej Kopr over 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
Low
Category:
Frontend
Target version:
Start date:
11/11/2019
Due date:
% Done:

100%

Estimated time:
Milestones:

Description

From project that use:

import { Enums } from 'czechidm-core';

And then:

<Basic.EnumSelectBox
    ref="status" 
    enum={ Enums.IdentityStateEnum }
    useSymbol={ false }
...

The selectbox doesn't show values. The issue is that EnumSelectBox doesn't throw error or some information message about empty props. Existing value in EnumSelectBox just missing.

As workaround can be used this:

import { IdentityStateEnum } from 'czechidm-core/src/enums/IdentityStateEnum';

Please add missing enums.


Related issues

Related to CzechIdM - Task #2242: Eav: Return form instance values by attribute filterClosed05/11/2020

History

#1 Updated by Ondřej Kopr over 1 year ago

  • Category set to Frontend

#2 Updated by Radek Tomiška 11 months ago

  • Related to Task #2242: Eav: Return form instance values by attribute filter added

#3 Updated by Radek Tomiška 11 months ago

  • Status changed from New to Closed
  • Assignee set to Radek Tomiška
  • Target version set to 10.4.0
  • % Done changed from 0 to 100

Also available in: Atom PDF

Go to top