Project

General

Profile

Defect #1729

After using Virtual system connector, you can't switch to remote connector server connectors

Added by Roman Kučera almost 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Low
Category:
Connectors
Target version:
Start date:
06/24/2019
Due date:
% Done:

100%

Estimated time:
Affected versions:
Milestones:

Description

Found on version 9.5.1
Reproduced on product 9.6.3

When you are using connector from remote connector server in some system and then you uncheck the option "use remote connector server" then you use Virtual system connector and then when you want to use connector server again you will get warning message that the password for remote connector server is invalid and you are not able to select connectors from the remote connector server in this system.
See below information how to reproduce it step by step and workaround for this.

Step to reproduce:
  • craete system a configure it for using remote connector server
  • Uncheck the checkbox "use remote connector server"
  • On Configuration tab use Virtual system connector and hit save
  • On Basic information tab check "use remote connector server"and fill password
  • Now you are not able to connector to it and IdM will return invalid password warning
Workaround:
  • Uncheck the checkbox "use remote connector server"
  • On Configuration tab select database connector for example (You can use any other connector)
  • On Basic information tab check "use remote connector server" and you will be able to connect again and select connector from remote server

Related issues

Related to CzechIdM - Defect #2210: Provisioning brake removes connector server key when it starts brakingClosed04/15/2020

History

#1 Updated by Vít Švanda almost 2 years ago

  • Target version set to Rhyolite (9.7.0)

#2 Updated by Vít Švanda almost 2 years ago

  • Target version changed from Rhyolite (9.7.0) to Rhyolite (9.7.3)

#3 Updated by Vít Švanda over 1 year ago

  • Target version changed from Rhyolite (9.7.3) to Rhyolite (9.7.5)

#4 Updated by Vít Švanda over 1 year ago

  • Target version changed from Rhyolite (9.7.5) to Rhyolite (9.7.6)

#5 Updated by Vít Švanda over 1 year ago

  • Assignee changed from Vít Švanda to Artem Kolychev

#6 Updated by Vít Švanda over 1 year ago

  • Target version changed from Rhyolite (9.7.6) to Rhyolite (9.7.7)

#7 Updated by Radek Tomiška over 1 year ago

  • Target version deleted (Rhyolite (9.7.7))

#8 Updated by Vít Švanda over 1 year ago

  • Assignee changed from Artem Kolychev to Ondrej Husník
  • Target version set to 10.1.0

#9 Updated by Ondrej Husník over 1 year ago

  • Status changed from New to In Progress

#10 Updated by Ondrej Husník over 1 year ago

  • Status changed from In Progress to Needs feedback
  • Assignee changed from Ondrej Husník to Radek Tomiška
  • % Done changed from 0 to 90

Could you please provide me a feedback for actually your own fix of this bug??
Thank you in advance.

https://github.com/bcvsolutions/CzechIdMng/pull/70/commits/93c47412454825504e925e934bef7cc20f160872

#11 Updated by Radek Tomiška over 1 year ago

  • Status changed from Needs feedback to Resolved
  • Assignee changed from Radek Tomiška to Ondrej Husník
  • % Done changed from 90 to 100

I did test and review, it works, thx!

#12 Updated by Radek Tomiška about 1 year ago

  • Status changed from Resolved to Closed

#13 Updated by Radek Tomiška about 1 year ago

  • Related to Defect #2210: Provisioning brake removes connector server key when it starts braking added

Also available in: Atom PDF

Go to top