Project

General

Profile

Actions

Task #1144

closed

Body(Text) is null when template is created via GUI

Added by Roman Kučera over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Roman Kučera
Category:
Notification
Target version:
Start date:
06/18/2018
Due date:
% Done:

100%

Estimated time:

Description

Steps to reproduce issue:
Create notification template in GUI. Fill only HTML body and leave text body empty.
Set this template to some action.
When this template should be send it fails on NullPointerException in DefaultIdmNotificationTemplateService on row this.velocityEngine.evaluate(velocityContext, bodyText, template.getCode(), text); because text is null.

Actions #1

Updated by Ondřej Kopr over 3 years ago

  • Target version set to Lapis (8.2.0)

The ticket will be implemented as fix in version 8.2.0. Thank you Roman for report.

Actions #2

Updated by Ondřej Kopr over 3 years ago

  • Status changed from New to Needs feedback
  • Assignee changed from Ondřej Kopr to Roman Kučera
  • % Done changed from 0 to 90

I fixed the problem, please Roman could you make a review? New tests are included.

Commit: https://github.com/bcvsolutions/CzechIdMng/commit/dda37950fdca40760c374052dbb50bb3a538dc40 (branch: develop)

Actions #3

Updated by Roman Kučera over 3 years ago

  • Status changed from Needs feedback to Closed
  • % Done changed from 90 to 100

I did review and test it. Now it's working nicely.
Thanks for quick fix.

Actions

Also available in: Atom PDF